Заметки WEB-разработчика

Полезные материалы для web-разработки

Расширение APC для PHP 5.5 и PHP 5.6

Если вам нужно установить и включить расширение php_apc для PHP 5.5 (или 5.6) в windows, есть способ сделать это. 

Но прежде чем сделать это, есть несколько вещей, которые вы должны знать:
  • Последний версии PHP, где был php_apc - PHP 5.3.
  • * Новые версии PHP заменили APC на php_opcache.
  • Последний релиз APC - php_apc 3.1.14
  • Доступен только APC 3.1.13, и, хотя это подходит для PHP 5.3 и 5.4, нужно понимать, что это только бета-версия 5,3 (то есть, не рекомендуется для PHP 5.4).
  • * Php_apc 3.1.13 не будет работать с PHP 5.5+.

Поэтому нужно ставить расширение php_apcu

Для этого скачайте его здесь: https://pecl.php.net/package/APCu/4.0.7/windows

Положите php_apcu.dll в папку со всеми расширениями php (у меня это: C:\Program Files\PHP-5.5\ext)

Откройте файл php.ini и настройте подобным образом:

extension=php_apcu.dll
apc.enabled=1
apc.shm_size=32M
apc.ttl=7200
apc.enable_cli=1
apc.serializer=php

Комментарии

Комментарии через Вконтакте